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'cpstart' command does not start Check Point services
Symptoms
  • Running 'cpstart' command ends immediately after printing "cpstart: Power-Up self tests passed successfully", and users get the command prompt.

  • Output of 'cpwd_admin list' command shows one of the following:

    • No processes in WD database
    • Failed to submit request to cpWatchDog
  • Output of 'ps auxww' command does not show the mandatory Check Point processes (cpd, fwd, etc.)

  • Running 'cpconfig' command shows:
    cpinst Error: Host name resolution for HOSTNAME failed.
    Local host name resolution is required for normal Check Point Security Gateway operation.
    Please correct this error and run cpstart again:
    Add an entry for HOSTNAME in /etc/hosts
  • Debug of 'cpstart' (per sk92987) shows that the 'CheckIP' test failed:
    cpstart: CheckIP failed, program terminate

  • Output of 'cat /etc/hosts' command shows only the entry for IP address "127.0.0.1".

  • In cluster, output of 'cphaprob state' command shows "HA module not started".

  • Policy installation failed with errors.

  • "fw_ipaddr: Unable to resolve ipaddr for *_* " error message when running the 'fwm -d load' command.

Cause

There is an issue with the configuration of the machine's hostname and the associated IP address.

The most common cause is when the First Time Configuration is performed through an interface, and then the IP address of that interface is removed / changed.

During the First Time Configuration, the IP address through which the administrator has connected and the hostname provided by the administrator are automatically added to the OS configuration (Gaia database and /etc/hosts file).

If that IP address is later removed / changed in the OS settings, the relevant entry is removed by the OS from the OS configuration (Gaia database and /etc/hosts file). If the administrator does not reconfigure the hostname and the relevant IP address, the required entry will not be defined in the OS configuration.

As a result, Check Point services fail to start because the required entry is not found in the OS configuration.


Solution

Follow these steps:

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  • Show / Hide instructions for Gaia OS

    1. Connect to the command line.

    2. Log in to CLISH.

    3. Set the machine's hostname (it should match the name of the corresponding object in SmartDashboard):

      HostName> set hostname HOSTNAME
    4. Set the machine's IP address associated with its hostname (this should be the IP address of the corresponding object in SmartDashboard):

      HostName> set host name HOSTNAME ipv4-address IPv4_ADDRESS

      If an IPv6 address is also configured on this machine, then run this command:
      HostName> set host name HOSTNAME ipv6-address IPv6_ADDRESS
    5. Save the Gaia database:

      HostName> save config
    6. Verify that the machine's hostname was configured correctly:

      1. Run in Clish:

        HostName> show host names
        Example output:
        Host Name                       IP Address
        Main_FW                         172.30.151.120
        localhost                       127.0.0.1
        localhost                       ::1
        

        Notes:

        • The order of entries does not matter.
        • There must be an entry with the hostname and IP address of the corresponding object in SmartDashboard.
        • There must be an entry with the hostname "localhost" and IP address "127.0.0.1".
        • If IPv6 is enabled, then there must be an entry with the hostname "localhost" and IP address "::1".
      2. Run in Expert mode:

        [Expert@HostName]# cat /etc/hosts
        Example output:
        127.0.0.1 localhost
        172.30.151.120 Main_FW
        ::1 localhost
        

        Notes:

        • The order of entries does not matter.
        • There must be an entry with the IP address and hostname of the corresponding object in SmartDashboard.
        • There must be an entry with the IP address "127.0.0.1" with hostname "localhost".
        • If IPv6 is enabled, then there must be an entry with the IP address "::1" with hostname "localhost".
    7. Reboot the machine.



  • Show / Hide instructions for SecurePlatform OS

    1. Connect to the command line.

    2. Log in to Expert mode.

    3. Run the sysconfig command.

    4. Select:

      1) Host name
    5. Select:

      1) Set host name
    6. Enter the host name (it should match the name of the corresponding object in SmartDashboard) and press Enter.

    7. Enter the IP of the interface to be associated with this host name (this should be the IP address of the corresponding object in SmartDashboard) and press Enter.

    8. When the confirmation appears - "The host name is set", press Enter.

    9. Press "e" to exit from this section of the sysconfig menu.

    10. Press "e" to exit from the sysconfig menu.

    11. Verify that the machine's hostname was configured correctly:

      [Expert@HostName]# cat /etc/hosts
      Example output:
      172.30.151.120 Main_FW
      127.0.0.1      localhost.localdomain localhost
      

      Notes:

      • The order of entries does not matter.
      • There must be an entry with the IP address and hostname of the corresponding object in SmartDashboard.
      • There must be an entry with the IP address "127.0.0.1" and hostname "localhost.localdomain localhost".
    12. Reboot the machine.

 

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