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SmartDashboard fails to get IPS updates when a proxy server is configured via Group Policy
Symptoms
  • SmartDashboard fails to get IPS updates when a proxy server is configured via Group Policy.

  • Output of Process Monitor tool shows that SmartDashboard searches for the proxy in the following Windows Registry key:

    FwPolicy.exe    xxx    RegQueryValue	HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\AutoConfigURL    NAME NOT FOUND
Cause

When an administrator has configured to automatically detect a proxy via group policy for IPS updates, the proxy is not automatically detected because the information has been searched in the incorrect Windows Registry key - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\AutoConfigURL.

According the Microsoft KB922704, there have been some changes in the Group Policy settings for Internet Explorer Security Zones in Microsoft Windows XP SP2 and in Microsoft Windows Server 2003 SP1 - the registry location has changed to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings.


Solution
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