Support Center > Search Results > SecureKnowledge Details
"Check Point's installer detected inconsistent file..." message when installing a software update using Gaia Software Updates
Symptoms
  • When installing a software update (Hotfix / Minor release) using CPUSE (sk92449), one of the following messages appears (depends on the version of CPUSE agent and on the package being installed):

    • Detected inconsistent files for installing this package.
      In order to successfully install the package, refer to sk97699.


    • Detected files that cannot be updated with a new content. For more information see sk97699.

    • Check Point's installer detected inconsistent files. To solve this, see sk97699.

    • Check Point's installer detected inconsistent files. Refer to the Patching Failure Report at the bottom of the installation log.

    • Check Point's installer detected inconsistent file versions due to a Hotfix installation. Uninstall the Hotfix and retry.

    • CPUSE detected inconsistent files on your machine.
      To solve this:
      1. Delete the package using the "Delete From Disk" CPUSE action.
      2. Refresh the display.
      3. Download the package again to allow installation.


    • CPUSE detected inconsistent files on your machine.
      Contact Check Point Technical Services for further assistance.
Cause

CPUSE process could not patch some files on the machine. This could be caused by several factors:

  1. A previously installed hotfix may have changed some files without properly generating a backup.

  2. A previously installed hotfix may have changed some files, but the original files were not found in the backup.

  3. Some files may have been manually changed on the machine.

Solution

(1) Action plan:

  1. Determine which files CPUSE failed to patch from the Patching Error Report. This report contains information about all files that were not patched and the reason for each file.

  2. Take the necessary steps based on the failure reason.

To get the Patching Error Report:

  • If the installation that failed was a hotfix package - refer to the bottom of the hotfix's installation log (in the /opt/CPInstLog/ directory) to see the Patching Error Report.

  • If the installation that failed was a minor version update - refer to the bundle's installation log file (in the /opt/CPInstLog/ directory) to get the path of the installation log of the failed package. Patching Error Report will be found at the bottom of that log.

 

(2) Procedure:

  1. If the files that CPUSE failed to patch were part of an installed Hotfix - uninstall the Hotfix and retry your installation.

  2. If the files that CPUSE failed to patch were modified by a user - try to get the original files (if they were saved).

  3. Contact Check Point Support to get the relevant CPUSE Full package.

  4. If none of the above reasons are applicable - contact Check Point Support and provide the following:

    • Patching Error Report from Gaia Portal
    • Complete contents of /opt/CPInstLog/ directory

 

(3) Related solutions:

Give us Feedback
Please rate this document
[1=Worst,5=Best]
Comment