Support Center > Search Results > SecureKnowledge Details
How to uninstall R75.47 from upgraded Security Management Server that manages Security Gateway 80 and 1100 appliances with WLAN or VAP interfaces through SmartProvisioning
Symptoms
  • Before uninstalling R75.47 from upgraded Security Management Server, user must remove all WLAN and VAP interfaces from Security Gateway 80 and 1100 devices running R75.20 that are managed by SmartProvisioning.

    If WLAN or VAP interfaces exist on these appliances, trying to connect with SmartProvisioning GUI client after uninstall of R75.47 might result in a crash of FWM daemon on Security Management Server.
Cause

WLAN and VAP interfaces are new classes in R75.47 database, and since they only exist in an ordered container, they are not removed in scheme adjust process that occurs during the uninstall.

As a result, the database after the uninstall includes objects with unknown schema. Trying to retrieve them when SmartProvisioning loads the objects causes the FWM daemon to crash.


Solution

Before uninstalling R75.47 from upgraded Security Management Server, user must use a special tool that performs the necessary maintenance operation on the objects (instead of physically removing all WLAN and VAP interfaces from Security Gateway 80 and 1100 devices that are managed by SmartProvisioning):

  1. Close all SmartConsole windows (SmartDashboard, SmartProvisioning, SmartView Tracker, SmartView Monitor, etc.).

  2. Connect to command line on Security Management Server / Multi-Domain Security Management Server (over SSH, or console).

  3. Backup the current database file $FWDIR/conf/prvn_tables.sqlite:

    [Expert@HostName]# cp $FWDIR/conf/prvn_tables.sqlite  $FWDIR/conf/prvn_tables.sqlite_ORIGINAL

  4. Download the special tool to correct the unknown schema in objects (Check_Point_R75.47_Uninstall_Hotfix_sk93776.zip) to your personal computer.

  5. Unpack the Check_Point_R75.47_Uninstall_Hotfix_sk93776.zip file.

    This ZIP file contains two folders:

    • Linux - contains the special tool for Gaia / SecurePlatform / Linux OS.

    • Windows - contains the special tool for Windows OS.


  6. Transfer the special tool to your Security Management Server / Multi-Domain Security Management Server:

    • For Security Management Server / Multi-Domain Security Management Server running on Gaia / SecurePlatform / Linux OS, transfer these files from "Linux" folder:
      • fix_R75_47_uninstall
      • fix_R75_47_uninstall_script.sh


    • For Security Management Server running on Windows OS, transfer this file from "Windows" folder:
      • fix_R75_47_uninstall.exe


  7. Run the special tool:

    Notes:
    • The special tool corrects the relevant attributes for objects.
    • This special tool does not replace any files.
    • On Multi-Domain Security Management Server server, this maintenance operation is carried out for each Domain Management Server server.
    • This tool creates a log file in the same folder from which is was run.


    Procedure:

    • On Security Management Server / Multi-Domain Security Management Server running on Gaia / SecurePlatform / Linux OS:

      1. Log in to Expert mode.

      2. Make sure both these files are located in the same directory:
        • fix_R75_47_uninstall
        • fix_R75_47_uninstall_script.sh


      3. Assign the relevant persmissions to both files:

        [Expert@HostName]# chmod a=rwx fix_R75_47_uninstall
        [Expert@HostName]# chmod a=rwx fix_R75_47_uninstall_script.sh

      4. Execute the shell script:

        [Expert@HostName]# ./fix_R75_47_uninstall_script.sh

        Note: This tool creates a log file in the same folder from which is was run.


    • On Security Management Server running on Windows OS:

      Right-click on the fix_R75_47_uninstall.exe - click on 'Run as administrator'.

      Note: This tool creates a log file in the same folder from which is was run.


  8. Uninstall R75.47 as described in the R75.47 Release Notes - chapter 'Uninstalling'.
This solution is about products that are no longer supported and it will not be updated
Applies To:
  • 01195694

Give us Feedback
Please rate this document
[1=Worst,5=Best]
Comment