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Users do not receive UserCheck page for blocked HTTPS content
Symptoms
  • User receives "Unreachable" message instead of a UserCheck page, when HTTPS Inspection is enabled and the gateway is configured as a proxy or the gateway is located between a client and a proxy.
Cause

When HTTPS connection is tunneled through HTTP proxy, the client sends HTTP "CONNECT" request as a first message.

If the gateway tries to reply with UserCheck redirect to such message, the result will be: the "Unreachable" message in browser. This happen cause most browsers are not supporting redirect reply on CONNECT request.


Solution
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