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Slow Mobile Access connectivity / Remote Access VPN client failed to download topology - from wireless or lossy networks Technical Level
Symptoms
  • When connecting from a mobile device via a wireless (or otherwise lossy) network to a Mobile Access gateway, Web and Secure Mail performance appears stuck or slow.
  • Connecting with Remote Access VPN fails connecting to the site with error:
    Download failed. Cannot download topology when connecting with VPN client.
  • Alternative scenario:
    Clients connect to a web site protected by Check Point Security Gateway with enabled HTTPS Inspection.
    When connecting over lossy networks, web page fails to load due to timeout.
    Traffic capture shows multiple TCP Selective Acknowledgement "SACK" packets between client and Security Gateway.
Cause

Both the Mobile Access gateway and the mobile device client implement a TCP feature called 'Selective ACK' (RFC 2018), where each party can acknowledge non-consecutive packets in order to save bandwidth. The current implementation of 'Selective ACK' might sometimes reduce performance instead of increasing it.


Solution
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