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Security Gateway cannot connect to Check Point Anti-Bot / Anti-Virus Online Web Services
|
Technical Level
|
Solution ID |
sk74040 |
Technical Level |
|
Product |
Anti-Bot, Anti-Virus, Application Control, URL Filtering |
Version |
R77.30 (EOL), R80.10 (EOL), R80.20 (EOL), R80.30 (EOL), R80.40 |
Platform / Model |
All |
Date Created |
30-May-2012
|
Last Modified |
24-Feb-2020
|
Symptoms
"Check Point Online Web Service failure. See sk74040 for more information.
" log in SmartView Tracker.
Security Gateway cannot connect to Check Point Anti-Bot Online Web Service / Anti-Virus Online Web Service.
"Internal error occurred, could not connect to cws.checkpoint.com
" alert log in SmartView Tracker for Application Control or URL Filtering blade.
Anti-Malware is not able to categorize a host out of a given URL if the hostname does not contain dots.
Cause
These Anti-Bot / Anti-Virus “Web service error” messages will be shown each time a request from the gateway to the ThreatCloud will be terminated with a timeout.
Possible causes:
- Connectivity issue - timeout while trying to connect to Check Point online service.
- Online Web Service access configuration problem - using Hold configuration for span port / tap installations.
- Memory allocation problem - the gateway's memory is overloaded.
- File extension sent to be scanned by the Anti-Virus blade contains spaces.
- Check Point kernel uses URL normalization routines to get the hostname out of a given URL checking if it contains a dot character (e.g., google.com instead of google). Some internal sites use hostnames without any dot characters, and in such cases URL validation fails. As a result, Anti-Malware is unable to categorize such host.
Solution
Note: Starting from R75.47 and R76, Anti-Bot Resource Classification mode for DNS is performed in the "background" on the Security Gateway. To learn more, see sk92224 - Resource Categorization for Anti-Bot / Anti-Virus DNS Settings optimization.
Follow these steps:
- Connectivity issue - timeout while trying to connect to Check Point online service.
Check the following:
- Check DNS configuration on the Security Gateway.
- Check Proxy configuration on the Security Gateway.
- Connectivity from the Security Gateway:
[Expert@GW]# curl_cli http://cws.checkpoint.com/AntiVirus/SystemStatus/type/short
This link should always be available and should always return a "true
" value:
<?xml version="1.0" encoding="UTF-8"?><response><allSystemsOK>true</allSystemsOK></response>
Note: For more information about the curl
, refer to cURL documentation.
- Online Web Service access configuration issue - using Hold configuration for span port / tap installations.
Configure the following:
- In SmartConsole / SmartDashboard, go to "Threat Prevention" tab -> expand "Advanced" -> click on "Engine Settings" -> in the "Resource classification mode" section, change from "Hold" to "Background".
- Install policy.
- Memory allocation issue - the Security Gateway's memory is overloaded.
- Wait for the memory consumption to decrease (for example, memory consumption is increased during policy installation, during IPS update, etc).
- If the memory exhaustion persists, contact Check Point Support for troubleshooting.
- File extension sent to be scanned by the Anti-Virus blade contains spaces
- Remove the file-extension property from the request (this will not affect the security of the Anti-Virus blade):
- On the gateway, edit the
$FWDIR/conf/rad_scheme.C
file (back it up before making the change).
- Delete the following two lines below "antivirus":
:const ("&file_ext=")
:value ("trapper:file_ext")
- Install policy on the gateway
- Users behind the Security Gateway try to access a non-standard URL, such as URL without dots.
Example: URL without .com at the end.
This problem was fixed. The fix is included in:
Check Point recommends to always upgrade to the most recent version (upgrade Security Gateway / upgrade Security Management Server / upgrade Multi-Domain Security Management Server).
Related solution: sk83520 - How to verify that Security Gateway and/or Security Management Server can access Check Point servers?
Applies To:
- This SK replaces sk97628
- 01309034 , 01313825