Support Center > Search Results > SecureKnowledge Details
Upgrade of Management Server on Windows OS might fail due to SNMP service
Symptoms
  • Upgrade of Security Management / Endpoint Security Management Server completes without error.

  • After Security Management / Endpoint Security Management Server machine is rebooted, FWM and FWD daemons are terminated with exit_code 128.

  • When "fw ver" command is executed on command prompt, the following error is shown:
    "fw.exe - Cannot find entry point" the procedure entry point CPEPS_set_sic_handle could not be located in the dynamin link library cpepscli.dll

  • When "fwm -d" command is executed on command prompt, the following error is shown:
    "fwm.exe - Cannot find entry point" the procedure entry point cplic_putkernel_enforce_mc_lic could not be located in the dynamin link library cpfwsys.dll

  • "Security Management Servers contain different Check Point products" in SmartDashboard menu >
    Policy > Management High Availability > under the 'Note' column.
    In addition, when comparing the Check Point installations in 'Programs and Features'
    Between the Primary and Secondary - "Endpoint Management" is missing:

  • On the Server in C:\Program Files (x86)\CheckPoint\CPInstLog\
    The most up to date "install_UEPM_R77.30.elg" shows:


Cause

SNMP Service was not stopped during the upgrade on Windows OS. This causes the upgrade to fail, and Security Management / Endpoint Security Management Server has to be re-installed from scratch.


Solution

Before the upgrade, disable SNMP Service:

  1. Go to Services:

    • Option 1:

      1. On the Desktop, right-click on My Computer icon - click on Manage.
        Computer Management window opens.
      2. In the left tree, click on Services and Applications - click on Services.
    • Option 2:

      1. In the Start menu, select Control Panel
      2. Double-click on Administrative Tools
      3. Double-click on Services
    • Option 3:

      1. In the Start menu, click Run...
      2. Type / paste services.msc
      3. Click OK / press Enter
  2. Find the SNMP Service.

  3. Right-click on SNMP Service - Stop.

  4. Perform the upgrade.

  5. Reboot the machine.

  6. Check the all relevant Check Point processes are running (run the following command in Windows Command Prompt):

    C:\> cpwd_admin list
  7. Check the SNMP Service is running (if not, then start it manually).

 

Related solutions:

Applies To:
  • 00552741 , 00556886 , 00556884
  • 00511543

Give us Feedback
Please rate this document
[1=Worst,5=Best]
Comment