Support Center > Search Results > SecureKnowledge Details
"Compatibility package is not properly installed or incorrectly configured" error on policy installation failure
Symptoms
  • "Compatibility package is not properly installed or incorrectly configured" error on Security policy installation failure after upgrading Security Management server from R77.30 to R80.20 with an in-place upgrade.

  • Output of cpprod_util CPPROD_GetKeyValues Products 0 command does not show R77.30 installed.
Cause

There are two possible reasons for this problem:

  1. All objects of type "Check Point nodes", such as gateways, Security Management servers, CLM, etc. should have a valid version associated with the object. If an object is imported and has no version selected, then the database installation process cannot determine if it needs to use a compatibility module to install the database and produces this error.

  2. The R80.20 compatibility package was not installed during in-place upgrade of Security Management server to R80.20. 

Solution
Note: To view this solution you need to Sign In .