Support Center > Search Results > SecureKnowledge Details
Usage for 'Read community' and 'Write community' on SmartDashboard Advanced SNMP tab Technical Level
Symptoms
  • SNMP Get/Set options on SmartDashboard do not appear to work.
  • Clicking the Dashboard get/set buttons on the SNMP property page of a gateway does not have an effect. The snmp.C file is configured, but get/set does not function.
  • The SmartDashboard's Advanced SNMP "read" and "write" communities permissions are not enforced with SNMP command line or other SNMP tools.
Cause
The SmartDashboard queries the standard SNMP daemon, which is why SmartDashboard does not populate the fields. The Check Point SNMPD daemon, which runs on port 260, reads the snmp.C file for configuration information. There is no way to force SmartDashboard to query the Check Point daemon on port 260.



The "Read" and "write" communities under the SNMP Advanced window of a FireWall-1 object have different functions than the "read" and "write" communities of the $FWDIR/conf/snmp.C file.



If the Check Point MIB is imported into an SNMP Management Server, queries to the Enforcement Module from the SNMP Management Server will operate properly.



NOTE:
Remember to have the SNMP management software query the Check Point MIB on port 260.
Solution
Note: To view this solution you need to Sign In .