Support Center > Search Results > SecureKnowledge Details
SmartConsle crashes/hangs while opening a policy package Technical Level
Symptoms
  • When attempting to open a Policy Package, SmartConsole would either hang for about 5min-20min and then load or it would crash and force us to quit the application.

  • On the client machine, the usage of RAM would continue to increase while the policy is attempting to open.

  • In some scenarios in an Multi-Domain environment, this will only occur on specific Domain(s).

  • Log file 'SmartConsole_1.log' might show (when taking SmartConsole debugs as per sk112334):

    Example:

    [18] [03 Aug 2021 02:33:39,462] (ERROR) CP.Infrastructure.UiFreezeMonitor - UI thread is frozen for 269369 ms. Freeze_R80.40_994000424_20210803022940.dmp
    [15] [03 Aug 2021 02:33:40,489] (ERROR) CP.Infrastructure.DLE.Rulebase.DleRulebaseClient - rulebase '<UID>' does not contain '<UID>'.
    [5] [03 Aug 2021 02:33:40,489] (ERROR) CP.Infrastructure.DLE.Rulebase.DleRulebaseClient - rulebase '<UID>' does not contain '<UID>'.
    [1] [03 Aug 2021 02:33:40,923] (ERROR) UICommon.SetDomainLayerCommand - Expected parameter to be object[], got null
    [1] [03 Aug 2021 02:33:40,923] (ERROR) UICommon.SetDomainLayerCommand - Expected parameter to be object[], got null
    [23] [03 Aug 2021 02:33:41,293] (ERROR) AppShellUI.AppShellNotifications - Recieved DiskSpaceNotification from the server. Message:
    [1] [03 Aug 2021 02:33:42,885] (ERROR) AccessCtrlPlg.Views.RuleStandardActionsViewModel - Current layer id is empty, can't load layers section in action context menu
    [1] [03 Aug 2021 02:33:42,953] (ERROR) AccessCtrlPlg.Views.RuleStandardActionsViewModel - Current layer id is empty, can't load layers section in action context menu
    ====== [ The same ERROR repeats multiples times ] ======
    [1] [03 Aug 2021 02:33:44,253] (ERROR) AccessCtrlPlg.Views.RuleStandardActionsViewModel - Current layer id is empty, can't load layers section in action context menu
    [1] [03 Aug 2021 02:33:44,969] (ERROR) CP.GuiInfrastructure.DLE.ObjectToBrushAsyncConverter - Failed to get resource 'General/globalsNa'

  • Log file 'SmartConsole_1.log' might also show (when taking SmartConsole debugs as per sk112334):

    Example:

    --- End of stack trace from previous location where exception was thrown ---
      at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
     at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
     at CP.GuiInfrastructure.IconKeyToBrushConverterBase.a.g()<---[1] [03 Aug 2021 02:33:44,973] (ERROR) CP.GuiInfrastructure.DLE.ObjectToBrushAsyncConverter - Failed to get resource 'General/globalsNa'
    System.AggregateException: One or more errors occurred. ---> System.Collections.Generic.KeyNotFoundException: resourceLocatorName
     at CP.Infrastructure.ResourceProvider.b.m()

    --- End of stack trace from previous location where exception was thrown ---
     at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
     at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
     at CP.GuiInfrastructure.IconKeyToBrushConverterBase.a.g()<---[1] [03 Aug 2021 02:33:45,039] (ERROR) CP.GuiInfrastructure.DLE.RulebaseListBoxPicker - could not get 'PART_ItemsDisplayer': cannot perform related bindings.
    [1] [03 Aug 2021 02:33:45,645] (ERROR) AccessCtrlPlg.Views.RuleStandardActionsViewModel - Current layer id is empty, can't load layers section in action context menu
    [1] [03 Aug 2021 02:33:45,694] (ERROR) AccessCtrlPlg.Views.RuleStandardActionsViewModel - Current layer id is empty, can't load layers section in action context menu

Solution
Note: To view this solution you need to Sign In .