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SSL Network Extender (SNX) disconnects randomly after upgrade to R81.x Technical Level
Symptoms
  • SSL Network Extender (SNX) disconnects randomly after upgrade to R81, R81.10, or R81.20.
  • SNX disconnects randomly on Chrome, Edge (based on Chromium), Firefox or Safari. The disconnection can happen within 2 minutes of being connected, or within a few hours.
  • These records can be found in the Portal Agent's log file (%temp%\CShell\cshell.elg):
    INFO [TunnelChecker] (TunnelChecker$DisconnectChecker run) Reached tunnel connection timeout. Disconnecting...
    [global] (Log log) [Director] Disconnecting the component.
    [global] (Log log) [Messaging] Sending DISCONNECT message
Cause
The issue takes place due to the "JavaScript throttling" feature of the Chromium engine. When this feature is enabled, the browser dramatically slows down JavaScript execution in non-active tabs. This affects the data exchange flow between the Portal Agent and the browser and results in SNX disconnection.


Solution

Overview

The fix for the issue is ready. It works for all browsers. 

The fix is available as a hotfixes for R81.x versions. It can be installed on standalone gateways, clusters HA/LS and VSX. Note - Due to continues changes in Chrome's engine we had to redesign the fix, which is why it is not yet included in a Jumbo Hotfix.
Important: The solution introduces some changes to the usual flow of working with the portal.

More details on UX changes
  1. It is possible to manage SNX connection at one tab only for all browsers. If end-user opens several tabs after SNX connection established, he will see appropriate message in that "secondary" tabs.

  2. Closing browser does not disconnects SNX. User is notified about it upon each connect. There is an option to hide the notifications.


    If browsers has been accidentally closed and SNX connection remained established, user needs to login to the Mobile Access portal again to disconnect SNX.


Prerequisites 

The previous solution for the issue must be uninstalled. Make sure that these hotfixes are not installed:
  • HOTFIX_R81_JS_THROTTLING_FIX_385_386_MAIN - for R81
  • HOTFIX_R81_10_JS_THROTTLING_FIX_438_MAIN - for R81.10
Please Install the New Hotfix Installation Packages Below:

Platform/Version Hotfix
R81 with Jumbo Take 56 or higher (TAR)
R81.10 with Jumbo Take 45 or higher (TAR)
R81.20 (TAR)
This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.

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