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Endpoint Security Client upgrade fails due to CryptoPro software Technical Level
Symptoms
  • Endpoint Security client upgrade fails due to CryptoPro software
  • The issue exists with Full Disk Encryption blade installed
  • In Endpoint Security Client installation log:
    FDE Log: Start upgrading preboot files:
    FDE Log: Failed to initialize ServiceMediaDriver, is the filter driver up and running?
    FDE Log: Failed to find mountable SA
    FDE Log: Upgrade failure.
    MSI (s) (14!D0) [08:27:57:343]: Product: Check Point Endpoint Security -- Error 27116.Upgrade failure. The installer failed to upgrade a legacy installation.
    
  • In %ProgramData%\Checkpoint\Endpoint Security\Full Disk Encryption\FDE_dlog.txt:
    20210405 101941,689+0400 I MsiExec.exe:848 FDEInstallDLL Start upgrading preboot files:
    20210405 101941,705+0400 I MsiExec.exe:848 Failed to initialize ServiceMediaDriver, is the filter driver up and running?
    20210405 101941,705+0400 I MsiExec.exe:848 FDEInstallDLL Failed to find mountable SA
    20210405 101941,705+0400 E MsiExec.exe:848 Upgrade failure.
    
  • In Endpoint Security Client installation log:
    MSI (s) (14!D0) [08:27:57:343]: Product: Check Point Endpoint Security -- Error 27569.Full Disk Encryption prepare installation failed.
    
Cause
During installation\upgrade of the Endpoint Security Client, the CryptoPro software injects its DLLs into the installation\upgrade process.


Solution
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