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How to remediate "Authentication failed - contact your Administrator" status after clean install of Endpoint client with Authentication token Technical Level
Symptoms
  • Endpoint client failed to register to server after installation. Authentication token is enabled on the server.
Cause
Authentication token is missing in the package used for installation or is expired/revoked.
Solution

Before start

Make sure the new Authentication token is generated on server and it is not expired

PowerShell with UI approach

Supported if PowerShell 3.0 or higher is installed

Win8 SP1 and newer OSes should be supported out of the box. Win7 SP1 needs an PowerShell update

PowerShell execution policy has to allow to run signed scripts or has to be bypassed otherwise

  1. Browse to folder %dadir%\bin in windows explorer.
  2. Right click on the file AuthToken.ps1
  3. Select "Run with PowerShell" option
  4. Following dialog should be opened after user agrees to run elevated PowerShell:
  5. Enter the value of the token guid generated on the server and press "OK"

Harmony Client should detect new value set and register to the Endpoint Security Management Server

PowerShell CLI approach

Supported if PowerShell 2.0 or higher is installed

Win7 SP1 and newer OSes should be supported out of the box.

  1. Open elevated PowerShell (with execution policy bypass, if needed) and change the directory using command "cd $Env:dadir"
  2. Execute following script ".\bin\AuthToken.ps1 [AuthToken]". As a parameter provide the value of the token guid generated on the server. For example running ".\bin\AuthToken.ps1 e84c7221-56b8-4c47-8066-85e13f10f0f7" as a result you should see following output: AUTH_TOKEN 'e84c7221-56b8-4c47-8066-85e13f10f0f7' written to the registry

Harmony Client should detect new value set and register to the Endpoint Security Management Server

Registry approach

  1. Open the Registry Editor on the client machine.
  2. Browse to "Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\CheckPointRW\Endpoint Security" on 64-bit windows and to "Computer\HKEY_LOCAL_MACHINE\SOFTWARE\CheckPointRW\Endpoint Security" on 32-bit windows
  3. If not exists - create a "String Value" entry with name "AUTH_TOKEN"
  4. Set the entry value to the token guid generated on the server

Harmony Client should detect new value set and register to the Endpoint Security Management Server

Reinstall using new package

  1. Uninstall the Harmony client that fails to register
  2. Export and download new package that includes the newly generated Authentication token
  3. Install new package. Make sure the Harmony client is registered to Server before the token is expired.

Reinstall using same package

  1. Uninstall the Harmony client that fails to register
  2. Install it again using same package with additional command line parameter using value of new Authentication token guid generated by Server
    EPS.msi AUTH_TOKEN=[AuthToken]
This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.

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