Support Center > Search Results > SecureKnowledge Details
"No upgrade tools package is installed for R80.xx version. To download the package manually, refer to sk135172. Restart verify process using -skip_upgrade_tools_check flag." - upgrade verification error when upgrading from R80.20 Technical Level
Symptoms
  • When upgrading from R80.20, running the R80.xx upgrade verifier shows:

    Host> installer verify X
    Info: Initiating verify of Check_Point_R80.xx_T294_Fresh_Install_and_Upgrade.tgz...
    Interactive mode is enabled. Press CTRL + C to exit (this will not stop the operation)
    Result: Verifier results Package: Check Point R80.xx Gaia Fresh Install and upgrade Clean Install: Installation is allowed. Upgrade: The following results are not compatible with the package:
    - No upgrade tools package is installed for R80.xx version. To download the package manually, refer to sk135172. Restart verify process using -skip_upgrade_tools_check flag.
    The R80.xx image you have imported is not supported for upgrade on:
    - Open Servers configured as a Security Gateway or Stand Alone.
    - Cloud environments (Microsoft Azure, Google Cloud, Amazon Web Service and Aliyun).
    - ClusterXL in Load Sharing mode with IPSec VPN blade enabled (this limitation does not apply to VSX in VSLS mode). See sk162637
    This R80.xx image is allowed for upgrade only on a machine with 64bit CPU
    To upgrade from R75.X, first upgrade to R77.30 and only then upgrade to R80.xx.


  • "$MDS_FWDIR/scripts/migrate_server verify -skip_upgrade_tools_check -v R80.xx" returns the same verification error:

    No upgrade tools package is installed for R80.xx version. To download the package manually, refer to sk135172. Restart verify process using -skip_upgrade_tools_check flag.

  • This dbget command returns nothing:

    [Expert@Host:0]# dbget installer:packages:R80.xx:installed_on
    [Expert@Host:0]#


  • When trying to install Check Point Upgrade Tools Package for R80.xx through CPUSE- this message shows:

    Newer or equal build of this package is already installed.
    Another build of this package is already stored on the machine.
    Please remove all stored builds of this package.


  • Output of “cpprod_util CPPROD_GetValue CPupgrade-tools-R80.xx BuildNumber 1” shows the build number of the Check Point Upgrade Tools Package for R80.xx:

    [Expert@Host:0]# cpprod_util CPPROD_GetValue CPupgrade-tools-R80.xx BuildNumber 1
    994000342
    [Expert@Host:0]#


  • Solution sk168635 does not help.
Cause
Check Point Upgrade Tools Package for R80.xx is not installed, but the registry file ($CPDIR/registry/HKLM_registry.data) has reference to the Check Point Upgrade Tools Package:


                        : (CPupgrade-tools-R80.xx
                                :CurrentVersion (6.0)
                                : (6.0
                                        :IsConfigured (1)
                                        :BuildNumber (994000330)
                                )
                        )

There are no “CPupgrade-tools-R80.xx” found in /opt:



Solution
Note: To view this solution you need to Sign In .