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Using the "set simple-gateway" API command with "logs-settings.forward-logs-to-log-server" fails with "Generic server error" Technical Level
Symptoms
  • When using API or SmartConsole CLI with the command: "set simple-gateway X logs-settings.forward-logs-to-log-server-name Y" the command fails.

  • In the file $FWDIR/log/cpm.elg similar errors are found:
    [DATE TIME] ERROR internal.query.QuerySvcImpl [qtp770863270-162]: query ALL_LOG_SERVER_OBJECTS not found
    [DATE TIME] WARN coresvc.internal.ObjectStoreJpaTransactionManager [qtp770863270-162]: rolling back the transaction.
    [DATE TIME] ERROR infrastructure.logging.DefaultExceptionLoggerHandlerImpl [qtp770863270-162]: incident [39f0776a-5f1a-44e2-9792-34e3b3298009]: CpmGeneralException{base='com.checkpoint.management.is.exceptions.CpmIllegalArgumentException: query not found ALL_LOG_SERVER_OBJECTS', errorCode='CP_ERR_ILLEGAL_ARGUMENT', errorFamily='null', messageForUser='null', message='query not found ALL_LOG_SERVER_OBJECTS'}
    [DATE TIME] ERROR dleserver.internal.DefaultExceptionMapper [qtp770863270-162]: Internal runtime error CpmGeneralException{base='com.checkpoint.management.is.exceptions.CpmIllegalArgumentException: query not found ALL_LOG_SERVER_OBJECTS', errorCode='CP_ERR_ILLEGAL_ARGUMENT', errorFamily='null', messageForUser='null', message='query not found ALL_LOG_SERVER_OBJECTS'}

Cause

A software limitation is causing the API command to try and utilize a non-existing query.


Solution
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