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Logs cannot be exported due to timeout Technical Level
Symptoms
  • In rare scenarios, logs cannot be exported from the Log server due to timeout.

  • $RTDIR/log/RFL.log file shows:
    DATE TIME,PID ERROR [pool-1-thread-36607] com.checkpoint.logs.LogServerRequestExecutor.call:47 - Error while handling request to [IP:8211]. uri: https://IP:8211/log_indexer_proxy/ping?ip=xxx, request data: []
    org.apache.http.conn.HttpHostConnectException: Connect to [IP]:8211 [/IP] failed: Connection refused (Connection refused)
    at org.apache.http.conn.HttpHostConnectException.(HttpHostConnectException.java:68)
    ...
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635)
    at java.lang.Thread.run(Thread.java:812)
    Caused by: java.net.ConnectException: Connection refused (Connection refused)


  • SmartView log shows:

    DATE TIME,PID WARN 1s0637cox0ykh1hv2zj960dez7 [Timer-9] (AbsTaskRunner.java:4)
    - task with uid {3EAA8EB7-B3B7-48F0-850D-E1903B4373D8} reached its timeout of 3600000 milliseconds
    2020-07-30 13:50:55,993 INFO o4gngzm7pqvrxme0jn3e5swa [TaskExecutor Worker 4] (ExportExcelTask.java:71)
    - Manually canceled Excel Export of uid : {0C0705C1-823D-4047-9F2D-40CBB66D64F2}
Cause
On rare occasions when specific filters are being used to export a very large amount of logs it can cause the export to timeout and fail.


Solution
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