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"Failed to connect to the server" error when trying to connect to CMA Technical Level
Symptoms
  • "Failed to connect to the server" error when trying to connect to CMA.
  • Running the procedure in sk118953 does not resolve the issue.
  • Following logs can be found in the fwm.elg log:
    Another Security Management Server is running
    Failed to connect to NGM server
    FwmMghaInit failed with error 80004005
    FwmMghaInit failed (0x80004005)
    ...
    Waiting until NGM server is up
    FATAL: Failed to execute query CPOBJ.NETWORK_OBJECTS_WITH_SIC with error=28
    FATAL: Failed to execute query CPOBJ.OPSEC_WITH_SIC with error=28
    FATAL: Failed to execute query CPOBJ.GET_BY_SIC_NAME with error=28
    fw_get_connected_tcp: failed to bind Virtual IP: Cannot assign requested address
    FATAL: Failed to execute query CPOBJ.GET_BY_SIC_NAME with error=28
    FATAL: Failed to create session on remote server
    Failed to initialize table manager: sRelativeDbPath = log_domain
    Failed to initialize database manager with error 0x80004005 ('Unspecified error')
    fwm_init_cpmi_pkg: WARNING : Failed to init log_domain database manager with err 0x80004005 (Unspecified error)
  • FWM crashes with a core dump.
Cause

Several soft links to essential directories such as bin, scripts, and cpm-server were missing in the $FWDIR directory of the CMA.


Solution
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