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When logging into FDE preboot with WebRemoteHelp account, [invalid login - account has expired] displayed and cannot login Technical Level
Symptoms
  • When logging into FDE preboot with WebRemoteHelp account, [invalid login - account has expired] is displayed and cannot login.
  • When logging into FDE preboot with domain admin account, [invalid login - account has expired] is displayed and cannot login.
  • On server side, expiration date is set as strange date, such as:
    expiration_date > 0001-01-03 00:00:00

    In epslog, it shows login with administrator account failed because the account is expired, but does not set the expiration date to the account.
  • User Check notification in OS: "The current FDE preboot user has been removed, locked, expired or not authorized to login so the computer will reboot in 30 seconds!"
  • The following error can be found in %PROGRAMDATA%\CheckPoint\Endpoint Security\Full Disk Encryption\dlog1.txt:
    DATE TIME W FDE_srv.exe:26d8 Could not get NETBIOS name from domain controller, reusing database domain value
    DATE TIME I FDE_srv.exe:12f4 Logsynchronizer: FDE log: Quid:3973448367 sent: 1 entries 
    DATE TIME W FDE_srv.exe:7d4 UserLockedUpdate The current preboot user has been either removed, locked, expired or not authorized to logon so Windows will reboot now! 
    
  • Endpoint Security Client fails to login Preboot
Cause
The issue is caused due to incorrect data types in SmartEndpoint.

When an admin creates a WebRH account, or new preboot user, without expiration date, the server enters a record with NULL in the expiration_date field in the user_node table in the DB.

Afterwards, if an admin updates these user names in "Users and Computers" tab, the server will override the expiration date for this user from NULL to 01/03/0001.


Solution
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