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SandBlast Mobile stops running on Android, device appears as "inactive" in dashboard Technical Level
Symptoms
  • SandBlast Mobile stops running on Android.
  • The device is marked as inactive in the dashboard.
  • When Working with Android Enterprise, the user sometime sees a notification that the Sandblast Mobile application was not installed on the personal profile (even if it is already installed).
Cause

The app is being killed by the operating system.

In order to save battery life, the operating system runs a battery optimizer which kills apps that run in the background for a long time.

Each vendor can implement a battery optimizer with a restricted strategy according to policy. In addition, the user can explicitly restrict an app. 


Solution

1. Always update to the latest SandBlast Mobile version.

2. In SandBlast Mobile 3.6.3, we added 2 ways to get permission for running in background.

The first way is in the on boarding screen. the Background activity switch will prompt for this permission.

           

The second way is a pop-up in the main screen which reminds the user to add SandBlast Mobile to the battery optimizer white list:

Both flows lead to this Operating system dialog and ask for permission to run in the background: 

However, some vendors, e.g., Huawei or Xiaomi do not follow the default implementation. Click here for more information.  

3.  Each vendor can define the battery optimizer strategy. In most devices, if the app is killed, the user must open it. 

This is an example of a battery optimizer's settings:

4. ONP VPN activation can prolong SandBlast Mobile's background lifetime.

5.  In case you are also using Check Point Capsule workspace - the capsule app may also be used to 'wake up' SandBlast Mobile.

6. If you press force stop, you will have to open the app again, as there will be no way to "wake it up". 

In addition some vendors has additional battery optimizer apps:

Huawei
App Launch (protected apps) from EMUI 8
Phone settings > Battery > App launch and then set your app to “Manage manually” and make sure everything is turned on.




Samsung
Optimizations apps:
• Android Pie and higher: Device care
• Android Oreo or Nougat: Device maintenance
• Android Marshmallow or below: Smart manager

Battery optimization is turned on by default. Some times after app update or OS update these settings might revert back to the defaults

Sleeping apps (list of apps not allowed to run on the background)
• Disable Put unused apps to sleep
• Disable Auto-disable unused apps
• Remove SBM from the list of Sleeping apps / Deep sleeping app
• Add SBM to the list of Apps that won’t be put to sleep
• Disable Auto-optimization
Note: the settings can be different for different OS.




OnePlus
App Auto-Launch
App Auto-Launch prevents apps from working in the background.
Please disable it for SBM.

This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.

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