Support Center > Search Results > SecureKnowledge Details
Migrate import fails with "Database export was done with migration tools for different version. You must export and import database with migration tools for version installed on destination machine" Technical Level
Symptoms
  • Import of the management database into a clean installed R80.20 machine fails with the following reason:
    "Database export was done with migration tools for different version. You must export and import database with migration tools for version installed on destination machine."

  • Attempting to run mds_import.sh, using a database from mds_setup generates the following error: Error: /var/log/exported_mds.DDMonYYYY-HHMMSS.tgz was created with a version of mds_export that does not match this version.
  • The /opt/CPshrd-R80.20/log/migrate-xxxx.xx.xx_xx.xx.xx.log shows:

    [DATE TIME] [ReadFwsetFile] Going to read file '/opt/CPsuite-R80.20/fw1/tmp/migrate//main_db/_plugin_upgrade_/plugin_pack.conf'
    [DATE TIME] [ReadFwsetFile] Succeeded to read file
    [DATE TIME] ...<-- ReadFwsetFile
    [DATE TIME] [PluginPackCompatibilityChecker::GetPluginPackId] Plugin pack id is: 'R80.20-GA'
    [DATE TIME] ..<-- PluginPackCompatibilityChecker::GetPluginPackId
    [DATE TIME] ..--> PluginPackCompatibilityChecker::GetPluginPackId
    [DATE TIME] [PluginPackCompatibilityChecker::GetPluginPackId] Reading plugin pack id information file located at '/opt/CPsuite-R80.20/fw1/bin/upgrade_tools/plugin_pack.conf'
    [DATE TIME] ...--> ReadFwsetFile
    [DATE TIME] ....--> UpgradeMacroReplacer::Instance
    [DATE TIME] ....<-- UpgradeMacroReplacer::Instance
    [DATE TIME] [ReadFwsetFile] Going to read file '/opt/CPsuite-R80.20/fw1/bin/upgrade_tools/plugin_pack.conf'
    [DATE TIME] [ReadFwsetFile] Succeeded to read file
    [DATE TIME] ...<-- ReadFwsetFile
    [DATE TIME] [PluginPackCompatibilityChecker::GetPluginPackId] Plugin pack id is: 'R80.20'
    [DATE TIME] ..<-- PluginPackCompatibilityChecker::GetPluginPackId
    [DATE TIME] [PluginPackCompatibilityChecker::exec] ERR: Plugin pack id on source machine is not identical to plugin pack id on destination machine
Cause

Plugin version defined in plugin_pack.conf does not match to the version defined in plugin_upgrade_match.conf. In plugin_pack.conf the version was defined as "R80.20-GA", while in the file plugin_upgrade_match.conf the version was defined as "R80.20".

This issue happens when /opt/CPupgrade-tools-R80.20 directory exist on one machine and not on another. This directory will be created automatically when user ticked the option to receive the updates from DownloadCenter automatically. 

plugin_pack.conf file will be updated automatically when device connected to the Internet and received the updates from DownloadCenter successfully. 


Solution
Note: To view this solution you need to Sign In .