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'Dynamic Id authentication failed' error message while trying to connect to Mobile Access portal Technical Level
Symptoms
  • 'Dynamic Id authentication failed' error message while trying to connect to the Mobile Access portal.
  • Log in Logs&Monitor shows: "DynamicID configuration error. Please contact your administrator."
  • Debug of cvpnd shows (cvpnd.elg):
    [AU] DynamicIDManager::triggerAsyncChallenge: failed to build emailTo/emailBody - abort
    [AU] DynamicIDSession::setState new_state -105 client_code 0 server_code 0 log_msg
    [AU] ....<-- DynamicIDManager::triggerAsyncChallenge
    [AU] ...<-- DynamicIDManager::sendNewAttempt
    [AU] ..<-- DynamicIDManager::sendToTarget
    [AU] DynamicIDManager::startDynamicID: sendToTarget failed
    [AU] ..--> DynamicIDManager::handleServerResponse
    [AU] DynamicIDManager::handleServerResponse: trigger callback
    [AU] dynamic_id_manager_callback state: -105
    [AU] dynamic_id_manager_callback(au=935dfc0): ePRIVATE_DID_CONFIGURATION_ERROR
    [AU] dynamic_id_manager_callback(au=935dfc0): fatal error - prevent new attempts
    [CPSC] cpsc_get_msg_by_id: Cache HIT for CPSC_DID_CONFIGURATION_ERROR
Cause

There is a space in configuration for "SMS Provider and Email Settings" (In this case, there is a space before BODY)

Looks like below:

mail:TO=$EMAIL;SMTPSERVER=smtp.example.com;FROM=sslvpn@example.com;

BODY=$RAWMESSAGE

Output looks like below:



Additional Configuration checks:
All "=" are in the relevant places.
All punctuation are in needed places.


Solution
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