Support Center > Search Results > SecureKnowledge Details
Fail to upgrade Multi-Domain Management in High Availability from R80.20.M1 or R80.20.M2 to R80.30
Symptoms
  • Failure when upgrading Multi-Domain Servers in High Availability from R80.20.M1 or R80.20.M2 with Advanced Upgrade, where one of the target R80.30 Multi-Domain Servers has a different IP address than the source.
Cause

A Special JSON file was not used as described in R80.30 Installation and Upgrade Guide, so upgrade failed on High Availability sync.

Every upgraded Multi-Domain Management server should have used a special JSON configuration file that describes the names and new IPs of the migrated Multi Domain Servers.
When there is an error in the file, or one of the Multi-Domain Management servers have been upgraded without the file, the upgrade will fail.


Solution
  1. If one of the Multi-Domain Management servers has been successfully upgraded, log-in with SmartConsole to the MDS domain and check the IPs of all Multi-Domain Management servers.

  2. If one of the new IPs is wrong, run the following:
    /opt/CPupgrade-tools-<TargetVersion>/scripts/changeSecondaryIpOnPrimary.sh -name <SecondaryMdsName> -ipAddress4 <NewIpAddress>

* Note: Use a relevant upgrade tools path according to target version. For example:
/opt/CPupgrade-tools-R80.30/scripts/changeSecondaryIpOnPrimary.sh -name SecondaryMds -ipAddress4 1.1.1.1

This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.

Give us Feedback
Please rate this document
[1=Worst,5=Best]
Comment