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SSL negotiation fails, "No client certificate was provided" error Technical Level
Symptoms
  • Although the Mobile Access Portal is set to use a user certificate for authentication, the portal does not prompt the MacOS user for this certificate. On a Windows device, there is no issue and the user is always prompted.
  • The following authentication error appears:
    [5568][26 Feb 7:50:34][RPC] Response: (192) (
    :value (GetAuthenticationInfoResponse
    :m_authenticateCertificateFirst (int
    :value (0)
    )
    :m_mdmPortalCookie (string
    :value ()
    )
    :m_errorCode (int
    :value (2)
    )
    )
    )
    
  • CCplogUtils::FillVarArg: str: SSL renegotiation fails with the following error: "No client certificate was provided."
Cause

This behavior is caused by MacOS keychain infrastructure.

The error itself indicates only that once the MacOS browser is not able to use a certificate, a handshake error occurs as expected. When the certificate is seen on the Security Gateway, there are no errors, which means that this is not a Gateway-side issue.


Solution
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