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SMB appliances randomly fail to communicate with SmartProvisioning
Symptoms
  • The appliances' status on SmartProvisioning is "Waiting" or "Not responding."
  • The appliances show random SIC or policy failure.
  • CPD debug shows:

    resolver_gethostbyname: Performing gethostbyname for [LSM profile name]
    resolver_gethostbyname: Failed to resolve hostname [LSM profile name]
    resolver_gethostbyname6: Performing getaddrinfo with PF_INET6 for host [LSM profile name]
    resolver_gethostbyname6: getaddrinfo failed. reason=Temporary failure in name resolution
Cause

The DNS is trying to resolve the LSM profile name, even though it should not be doing so.

It takes a long time for the query to fail (several seconds), during which time  the CPD on the Management\CMA is unavailable.


Solution
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