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Revisions view in SmartConsole fails with "Unable to connect to server" error Technical Level
Symptoms
  • "Unable to connect to server" error when trying to view revisions while connecting to the Security Management server via different management interface or Management server's DNS name.

  • The $FWDIR/log/cpm.elg file shows:
    DATE TIME,PID ERROR coresvc.internal.SsoManagerImpl 
    [qtp703048122-358494]: failed to generate SSO token for fwm session id {EB4F39D0-6B7B-FD41-A4B0-7BA24A3E1DB3}
  • The FWM debug shows:
    [FWM PID]@Hostname[DATE TIME] --> 0x0aaf03e0 CSeamFwmAddon::_schedConnectToSeamServer
    [FWM PID]@Hostname[DATE TIME] .--> 0x0aaf03e0 CSeamFwmAddon::_connectToSeamServer
    [FWM PID]@Hostname[DATE TIME] CSeamFwmAddon::_connectToSeamServer : srvGetNamedResourceInfo failed
    [FWM PID]@Hostname[DATE TIME] .<-- 0x0aaf03e0 CSeamFwmAddon::_connectToSeamServer
    [FWM PID]@Hostname[DATE TIME] CSeamFwmAddon::_schedConnectToSeamServer - _connectToSeamServer failed
    [FWM PID]@Hostname[DATE TIME] <-- 0x0aaf03e0 CSeamFwmAddon::_schedConnectToSeamServer
Cause

When we trying to view a revision, SmartConsole tries to connect to the IP address defined on the security management object. Not to the IP address SmartConsole session uses.

This can also cause due to the fact Smartconsole connect to a NAT address instead of the real address of the security management server.

Other case might be due to sort of proxy.


Solution
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