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Upgrade to R80.20.M2 fails with error code "CP_ERR_FILE_NOT_FOUND" Technical Level
Symptoms
  • During upgrade from R80.20 to R80.20.M2, export might fail with "Failed to export: Export failed." / "Failed during export process".
  • CPM Doctor test 'IPS silent package in DB' fails.
  • The $MDS_FWDIR/log/cpm.elg* file shows:
    "Failed to perform export for domain a0bbbc99-adef-4ef8-bb6d-cebcebcebceb with error: 
    java.lang.RuntimeException: 
    CpmGeneralException{base='com.checkpoint.management.is.exceptions.CpmGeneralException', errorCode='CP_ERR_FILE_NOT_FOUND', 
    errorFamily='Can't find file with ID:XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX
    
Cause

IPS package is missing from the Security Management database.


Solution

This problem was fixed. The fix is included in:

This problem does not happen in R80.30.

Check Point recommends to always upgrade to the most recent version (upgrade Security Gateway / upgrade Cluster / upgrade Security Management Server / upgrade Multi-Domain Security Management Server).

 

In versions prior to R80.30, before exporting the management database with Upgrade Tools package at sk135172, run the following command on the Security Management server:

touch /var/log/upgrade_export_verify_ips_pkg_exists

 

After the export completed successfully, on the Security Management Server, run

rm /var/log/upgrade_export_verify_ips_pkg_exists

This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.

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