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"NAT Hide failure " error in SmartLog / SmartView Tracker Technical Level
Symptoms
  • "NAT Hide failure - there are currently no available ports for hide operation" appears in SmartLog/SmartView Tracker.
Cause

The number of connections with the same hide ip, to the same destination exceeds the available ports.

Limitation - We have a maximum of 50,000 ports per pool - <hide ip, destination, IP Protocol>.

Therefore it is possible to have more than 50,000 simultaneous NATed connections, thus reaching port exhaustion, because we are hiding all the networks behind 1 IP - of the Gateway, and all the connections maps to the same pool.


Solution
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