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New objects not being added when scanning AD
Symptoms
  • When scanning the AD, new objects are not detected and added to the SmartEndpoint Users and Computers tab.
  • Logs show:
    ERROR Dispatcher-Thread-10 - Error on close application transaction  (LocalUepmSynchronizer)
    com.checkpoint.uepm.backend.is.exceptions.TxException: 
    TICKET_NUMBER = XXXXXXXXXX. ADMIN_ID = ds_admin_admin_nid_pool-6-thread-3, ADMIN_NAME = ds_admin_admin_nid_pool-6-thread-3. 
    Transaction was terminated because one of update commands failed.
    	... more
    Caused by: com.checkpoint.uepm.backend.is.exceptions.CommandException: 
    TICKET_NUMBER = XXXXXXXXXX. COMMAND_NAME = createOrUpdateGroupCommand. 
    The command failed in DAO.
    	... 8 more
    Caused by: com.checkpoint.uepm.backend.is.exceptions.DaoException: 
    TICKET_NUMBER = XXXXXXXXXX. 
    AddNodeParent by iBATIS failed. 
    	... 11 more
    Caused by: com.ibatis.common.jdbc.exception.NestedSQLException:   
    --- The error occurred in sqlMap/directoryScanner.xml.  
    --- The error occurred while applying a parameter map.  
    --- Check the AddNodeParent-InlineParameterMap.  
    --- Check the statement (update failed).  
    --- Cause: org.postgresql.util.PSQLException: ERROR: index "node_parents_pkey" contains unexpected zero page at block 13
      Hint: Please REINDEX it.
    
Cause

The error in the logs signifies that there is some corruption in the index.  Table will need to be re-indexed.


Solution
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