Support Center > Search Results > SecureKnowledge Details
"A secondary session request was received from the same IP" message in Identity Awareness log Technical Level
Symptoms
  • SmartLog error "A secondary session request was received from the same IP. This caused logout of the current session".
Cause

Most of the Identity Awareness sources (except for AD Query, which is configurable) overwrite existing information related to the same IP address.

Therefore, when the PDP server receives a new user association, the old data for this IP will be overwritten, and a log message stating that "A secondary session request was received from the same IP. This caused logout of the current session" will be presented in the SmartLog.

The PDP flow is as follows:

  1. Identity information is received for IP x.x.x.x
  2. PDP checks if we already have information for IP x.x.x.x in our database.
  3. IP x.x.x.x is associated with information for different user name / machine name.
  4. At this juncture, new user name / machine information will overwrite the old one.
  5. The message "A secondary session request was received from the same IP. This caused logout of the current session" will be shown in SmartLog.

Solution
Note: To view this solution you need to Sign In .