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Upgrading Security Management from R77.x to R80.10 fails
Symptoms
  • Migrate import or in place upgrade from R77.x to R80.10 fails.
  • The user sees the following error in the file /opt/CPInstLog/{relevant upgrade directory}/logsFromPostVersion/opt/CPsuite-R80/fw1/log/{relevant log file}.elg:

    (e.g., /opt/CPInstLog/install_Major_R80.10_T430.logDir/logsFromPostVersion/opt/CPsuite-R80/fw1/log/upgrade_from_fwm_on_domain_41e821a0-3720-11e3-aa6e-0800200c9fde.elg)

    ERROR com.checkpoint.management.upgrade.Dispatcher.dispatch:29 [main] - Exception caught during upgrade: For input string: "4294967295" java.lang.NumberFormatException: For input string: "4294967295" at java.lang.NumberFormatException.forInputString(NumberFormatException.java:76) at java.lang.Integer.parseInt(Integer.java:595) at java.lang.Integer.valueOf(Integer.java:778) at com.checkpoint.infrastructure.data_structures.Fwset.getInteger(Fwset.java:28) at com.checkpoint.management.upgrade.action.AntiMalwareExceptionRulebaseSectionUpgradeAction.upgrade(AntiMalwareExceptionRulebaseSectionUpgradeAction.java:45) at com.checkpoint.management.upgrade.Dispatcher.dispatch(Dispatcher.java:2) at com.checkpoint.management.upgrade.UpgradeServer.fetchAndDispatchUpgradeRequest(UpgradeServer.java:58) at com.checkpoint.management.upgrade.UpgradeServer.performUpgrade(UpgradeServer.java:3) at com.checkpoint.management.upgrade.UpgradeServer.runServer(UpgradeServer.java:12) at com.checkpoint.management.upgrade.UpgradeServer.main(UpgradeServer.java:80)
Cause

During the upgrade process, there is a max uint value (4294967295) under "anti_malware_exception_rulebase_section" that is not automatically converted to int max value (2147483647). In R80.10, Java reads the int max value of (2147483647). 


Solution
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