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"There are no log servers available" error and SmartConsole does not display logs Technical Level
Symptoms
  • “There are no log servers available, check your log server configuration” error is shown when trying to query in SmartConsole.
  • Running the command: "tail -f $RTDIR/log_indexer/log/log_indexer.elg" is showing logs similar to:
    [log_indexer PID]@EXAMPLE[DATE TIME] ServerObjectTranslator::handleNetworkObject - the object is not LogServer/SmartEvent/management/MDS/MLM/CLM/CMA and will be skipped:
    [Server Id: [uuid:e9e67b9d-fc4b-4f3f-9381-36d7b8c7d28a][domain uuid:41e821a0-3720-11e3-aa6e-0800200c9fde][name:][domain name:][sic name:][deleted:0]; Server Attributes: [is LogServer:0]
    [is Primary:0][is Management:0][is SmartEvent:0][Hosted MDS name:][Hosted MDS uuid:][Hosted MDS ip:][IPv4:][IPv6:][is Old Version:0]; is Mirror: 0; full synced name: Net_xx.xxx.xx.xx].
    [log_indexer PID]@EXAMPLE[DATE TIME] ServerObjectTranslator::updateMyDataNoLockFromLocalMaps: get sic name from the registry - cn=cp_mgmt,o=EXAMPLE.domain.com.7hjsdc
    [log_indexer PID]@EXAMPLE[DATE TIME] ServerObjectTranslator::updateMyDataNoLockFromLocalMaps: there is no such object with this sic name: [cn=cp_mgmt,o=EXAMPLE.domain.com.7hjsdc].
    [log_indexer PID]@EXAMPLE[DATE TIME] ServerObjectTranslator::updateMyDataNoLockFromLocalMaps: the object with this sic name: [cn=cp_mgmt,o=EXAMPLE.domain.com.7hjsdc] is NULL.
    [log_indexer PID]@EXAMPLE[DATE TIME] ServerObjectTranslator::Init: Force update RFL/SOLR about current log_servers running configuration.
Cause

Multiple objects containing the same IP address are configured.


Solution
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