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"There are no log servers available, check your configuration" message when shifting to Logs & Monitor view Technical Level
Symptoms
  • "There are no log servers available, check your configuration" message when the user shifts to the Logs & Monitor view in SmartConsole.

  • Output of # psql_client cpm postgres -c "select fwset from dleobjectderef_data where cpmitable='sem_network_objects' and name ilike '%OBJ_NAME%' and deleted='f' and dlesession='0';"
             :log_indexer (true)                        +
             :ips_event_manager (false)                 +
             :hosted_by_mds ("MDS_NAME")            +
             :uf_integrated (false)   
  • $RTDIR/conf/logServerConfig.xml shows the Domain Management Server IP address in the ProxyIp field and the IPAddress field. The ProxyIp field must be the MDS IP address.


    <connection>
    <IPAddress>192.168.1.10</IPAddress>
    <IsLocalIp>true</IsLocalIp>
    ...
    <ProxyIp>192.168.1.10</ProxyIp>
    </connection>

  • In SmartConsole, when the user browses to the Logs tab and, in the right section, to Log Servers, this error appears:
    "Problems have occurred during search".

  • When the user you clicks on view details, this message appears:
    "Log Server is not configured (IP: X.X.X.X), make sure that you published all changes".

Cause

An incorrect Provider object name is in the hosted_by_mds value.


Solution
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