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MTA not generating the "undeliverable message" when an email is rejected Technical Level
Symptoms
  • A device other than the Check Point MTA is rejecting an email message forwarded through the MTA, but the Check Point MTA is not generating the "undeliverable message" to be sent to the original source of the email.
Cause

This is expected behavior.  There are two circumstances surrounding rejected emails and how the Check Point MTA would handle them:

  1. Our MTA decides to bounce (reject) a message (for example when sending a message to an undefined user on a domain configured on MTA forwarding rules). In this case our MTA would send a bounce (reject) message back to the sender, using the relevant rule for the sender domain configured on MTA forwarding rules.

  2.  A device after the Check Point MTA decides to bounce (reject) a message after it accepted the message for delivery. In this case that device would send the bounce (reject) message to the sender. If that device is configured to send the reject message to the sender through our MTA, then our MTA would treat it as a regular message, process it and relay it to the sender domain configured in the MTA forwarding rules.

Solution

No solution required - expected behavior.  The Check Point MTA is only designed to generate the bounce (reject) message if it is the source of the rejection.

If another device makes the rejection, it is that device's responsibility to generate the bounce (reject) message for the original source and the Check Point MTA would forward it as long as it is in line and configured to forward the message based on it's MTA forwarding rules.

This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.

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