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Security Gateway configured as MTA does not forward e-mails that contain attachments in TNEF format, or forwards them very slowly Technical Level
Symptoms
  • Security Gateway configured as MTA does not forward e-mails that contain attachments in TNEF format, or forwards them very slowly.

  • Output of 'top' / 'ps auxw' / 'vmstat 1' commands on Security Gateway show high utilization of RAM and hard disk.

  • $FWDIR/tmp/email_tmp/ directory and /tmp/scrub/ directory on Security Gateway contain large number of temporary files.

  • MTA debug (according to sk109699) shows:

    [emaild.mta PID]@HostName[DATE TIME] email_policy_scrub_replace_part: running AM_attachment_replace (attachment_id = winmail.dat, scrubbed_disk_file = /opt/CPsuite-R77/fw1/tmp/email_tmp/emailtemp-XXX._tnef_dst)
    [emaild.mta PID]@HostName[DATE TIME] mime_alter.c:4344:AM_replace_attachment: attachmentname before magic: (null)
    [emaild.mta PID]@HostName[DATE TIME] mime_alter.c:4357:AM_replace_attachment: magic not given
  • After enabling generation of core dump files per sk92764, core dump files for 'in.emaild.mta' process were generated in the /var/log/dump/usermode/ directory.

Cause

The MTA process in.emaild.mta crashes when Threat Extraction blade is enabled and e-mail with an attachment in the TNEF (Transport Neutral Encapsulation Format) format is being cleaned/converted.


    Solution
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