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SmartConsole / SmartDashboard issues due to corrupted plugin_metafile.C file
Symptoms
  • The below article provides solution for different scenarios when problem arises because of corrupted $FWDIR/conf/plugin_metafile.C file.
    Please see the below symptoms and follow the solution.


  • GuiDBedit Tool crashes on every search (for any object) and on every double-click on any object.

    TraceUtil debug of the Database Tool contains the following error message:
    [SRVIS] Failed to open cpml_dir\conf\plugin_metafile.C
  • After in-place Multi-Domain Management server upgrade, users cannot log in with the new version of SmartDomain Manager, receiving "Before you can connect to server x.x.x.x, you need to install SmartConsole (Previous Version)" error.

  • After uninstalling the Upgrade package, when trying to connect with SmartDashboard, a SmartConsole update window pops up and asks for an update. After clicking "Update", it starts to download/extract the SmartConsole Update package, but it is not updated in fact.
    As the result, the GUI cannot connect to the SmartDashboard.

  • "Server Error Code" message pops up when launching the Multi-Domain Management GUI.

    "Error running cpdb new" and "Failed during CPMI upgrade" messages in the MDS debug output (fw debug mds on TDERROR_ALL_ALL=5)
Cause

The $FWDIR/conf/plugin_metafile.C file on the Security Management server is corrupted or is not updated (contains wrong version).

Another reason is that during the SmartConsole installation, the Demo Mode was not checked. Therefore the plugin_metafile.C file is missing from the GUI client machine.


Solution
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