Support Center > Search Results > SecureKnowledge Details
Postgres process does not start after installing Take 205 /216 / 225 of R77.30 Jumbo Hotfix on SmartEvent server
Symptoms
  • The postgres process does not start after installing Take 205 /216 / 225 of R77.30 Jumbo Hotfix.

  • "pg_ctl: error while loading shared libraries: libkrb5.so.3: cannot open shared object file: No such file or directory" error when running the following command:
    su cp_postgres -c "pg_ctl start -l logfile -D /opt/CPrt-R77/events_db/data/"

  • The following error appears when connecting to SmartReporter Database:
    [Expert@HostName]# $CPDIR/database/postgresql/bin/psql -U cp_postgres -p 18272 rt_database psql: could not connect to server: No such file or directory
    Is the server running locally and accepting connections on Unix domain socket '/tmp/.s.PGSQL.18272'?
  • Authentication Failure" error when trying to connect with SmartEvent GUI.
Cause

The postgres process fails to start because during the uninstall of Take 159 of R77.30 Jumbo Hotfix Accumulator, the relevant permissions are not restored.


Solution
Note: To view this solution you need to Sign In .