Support Center > Search Results > SecureKnowledge Details
Access to HTTPS sites is intermittent - web site opens only after the user refreshes the page several times
Symptoms
  • Access to HTTPS sites is intermittent - web site opens only after the user refreshes the page several times in the following scenario:

    • URL Filtering blade is enabled
    • In SmartDashboard, go to "Application & URL Filtering" tab - expand "Advanced" - click on "Engine Settings":
      • "Fail Mode" is set to "Block all requests (Fail-close)"
      • "Website categorization mode" is set to "Hold"
    • HTTPS Inspection is enabled
  • /var/log/messages file on Security Gateway repeatedly shows:
    ;cpas_tcp_pass_data: asked to transfer XXX bytes which is more than in q(YYY), app ws_app

  • Kernel debug ('fw ctl debug -m WS all') on Security Gateway shows that when some held HTTPS connection is resumed, it is dropped:

    :{body} [SID: ...] ws_body_stream_resume: [ERROR]: the filter offset (XXX) is larger than the stream's length (YYY);
    :{body} [SID: ...] ws_abs_stream_default_set_reading_context: [ERROR]: couldn't resume the stream;
    :{body} [SID: ...] ws_filter_mgr_execute_filter_chain: [ERROR]: set filter context to: SIGNATURE, failed;
    :{session} [SID: ...] ws_http_process_body: [ERROR]: failed to execute filter chain;
    :{session} [SID: ...] ws_http_session_server_read: [ERROR]: failed to process body;
    :{connection} [SID: ...] ws_connection_read_handler: [WARNING]: read request from session failed sn: ZZZ;
Solution
Note: To view this solution you need to Sign In .