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First Time Configuration Wizard is stuck at 90%
Symptoms
  • First Time Configuration Wizard is stuck in web browser at 90% (even after several hours).

  • Traffic capture on the Host (from which user connects) shows that the web browser repeatedly sends HTTP "GET" requests, but the Check Point Security Gateway does not respond.

  • Development Tools in the web browser (e.g., Chrome, Firefox) show that the web browser repeatedly sends HTTP "GET" requests to the Check Point Security Gateway, but the Check Point Security Gateway does not respond.

    Example from Firefox:
  • Output of "netstat -ant | grep -E "Proto|443|<IP_of_Host>" command on the Check Point Security Gateway shows that connection from Check Point Security Gateway to the Host is stuck in the "FIN_WAIT2" state.

    Example:
    [Expert@HostName:0]# netstat -tan | grep -E "Proto|443|<IP_of_Host>"
    Proto Recv-Q Send-Q Local Address               Foreign Address             State
    tcp        0      0 <IP_of_Appliance>:443       <IP_of_Host>:<Port>         FIN_WAIT2
    
Cause

TCP specification does not state that the "FIN_WAIT_2" state has a timeout (reference: https://httpd.apache.org).
In some cases, this can cause the TCP connection not to terminate.

Per RFC 793:
FIN-WAIT-2 - represents waiting for a connection termination request from the remote TCP.


Solution
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