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Errors during Threat Emulation update
Symptoms
  • Threat Emulation engine update (or any Threat Emulation updateable component) download fails with "Threat Emulation update failed, cannot download <Name_of_Component>. Failed running download process." log in SmartLog / SmartView Tracker.

    Example:
  • "Error: Threat Emulation update failed, cannot download JAVA. Failed running download process." status appears for Threat Emulation blade in SmartView Monitor.

    Example:
  • The $FWDIR/log/te_file_downloader.elg file shows:

    [ERROR] http_client_get: Operation failed. curl returned:Errorcode=35. Error String:SSL connect error
    Error Buffer=<NULL>
    [ERROR] FDT_get_data: Failed to get data (curl error: -1) from https://updates.checkpoint.com/WebService/services/DownloadMetaDataService 
    [TE (TD::All)] file_DataCB: ==> status: 2
    [TE (TD::Critical)] file_DataCB: Got bad FDT status 2
    [TE (TD::Critical)] get_file: Failed getting data from FDT for product (te_image), error: General Error
    [NOTICE] http_client_destroy: Free HttpClient memory - Done.
    [TE (TD::Critical)] main_te_fileDownloader: failed getting file
     
Cause

Check Point Update Center updates.checkpoint.com has moved to SHA-256 based certificates (refer to sk103839).
However, the version of Threat Emulation engine that is used does not support SHA-256 based certificates.


Solution

This problem was fixed. The fix is included in:

 

Related solutions:

Applies To:
  • 02349820
  • 02338507

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