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iTunes application cannot log in when HTTPS Inspection is enabled
Symptoms
  • The iTunes application is not able to connect, or user cannot log in.
  • SmartView Tracker / SmartLog shows logs of the gsa.apple.com certificate not being signed by a trusted CA.
  • Bypassing HTTPS Inspection using a custom site *.apple.com or gsa.apple.com does not resolve the issue.
Cause

Apple uses certificate pinning in their iTunes application, and iTunes application refuses the connection when a self-signed certificate signed is offered by the Security Gateway with enabled HTTPS Inspection. 


Solution
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