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Version of ESOD Compliance Updates on Mobile Access Gateway does not change after successful update
Symptoms
  • Endpoint Compliance was updated successfully in SmartDashboard ('Mobile Access' tab - expand 'Endpoint Security On Demand' - click on 'Endpoint Compliance Updates' pane - click on 'Update Databases Now...' button) and policy was installed successfully.
    However, SmartView Monitor shows that the "Version" is not the latest available.

  • Output of avsu_client -app "ICS" fetch command (per sk50361) on Mobile Access Gateway shows that manual Compliance Scanner update succeeds:

    [Expert@HostName:0]# avsu_client -app "ICS" fetch
    signature file up to date
    err_str=Succeeded. Existing signature is up-to-date.
    info=
    Local version is date
    
  • However, $CVPNDIR/htdocs/ICS/components/ics4.ver file shows that the "Version" is not the latest available.

Cause

During the Compliance Scanner update on Mobile Access Gateway, the $CVPNDIR/bin/ics_updates_script script places the new version files into $CVPNDIR/conf/ directory instead of $CVPNDIR/htdocs/ICS/components/ directory:

  • $CVPNDIR/htdocs/ICS/tmp_updates/extracted/ics4.ver is placed into $CVPNDIR/conf/ics4.ver, instead of $CVPNDIR/htdocs/ICS/components/ics4.ver

  • $CVPNDIR/htdocs/ICS/tmp_updates/extracted/ics_build.ver is placed into $CVPNDIR/conf/ics_build.ver, instead of $CVPNDIR/htdocs/ICS/components/ics_build.ver


Solution
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