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Users with non-English characters in their user names are not able to login in Endpoint Security VPN clients if Security Gateway is managed by R80 / R80.10 Security Management Server
Symptoms
  • Users are not able to login in Endpoint Security VPN clients in the following scenario:

    1. User name contains non-English characters
    2. Version of Endpoint Security VPN client is earlier than E80.60
    3. Security Gateway is managed by R80 / R80.10 Security Management Server
    4. Policy was installed on Security Gateway at least once after importing the management database into R80 / R80.10 Security Management Server
Cause

R80 and above Security Management Server use the Unicode character set and the UTF-8 encoding to store non-English characters.

Endpoint Security VPN clients earlier than E80.60 do not support UTF-8 encoding.

SmartDashboard R77.X and lower allows the user to use encodings other than UTF-8 for non-English characters in the properties of an internal user name object.

User names (that were defined in SmartDashboard R77.X and lower) that contain non-English characters will be corrupted during policy installation on R80 / R80.10 Security Management Server.

Example of an internal user name with non-English characters (as seen in R80 / R80.10 SmartConsole):


Solution

Follow these steps to prevent / resolve this issue:

  1. Find which non-Unicode encoding is used on the Windows SmartConsole machine:

    1. Download this utility that detects and displays the encoding (for list of supported encodings, refer to sk109795).

    2. Extract and run the utility on the Windows SmartConsole machine.

    3. Write down / copy the displayed non-Unicode encoding.

    4. Close the utility.

  2. Change the non-Unicode encoding in management database:

    1. Close all SmartConsole windows (SmartDashboard, SmartView Tracker, SmartView Monitor, etc.).

    2. Connect with GuiDBedit Tool to Security Management Server / Domain Management Server.

    3. In the upper left pane, go to Table - Global Properties - properties.

    4. In the upper right pane, select the firewall_properties.

    5. Press CTRL+F (or go to Search menu - Find) - paste encoding - click on Find Next.

    6. In the lower pane, right-click on the encoding - select Edit... - delete the UTF-8 string - enter the non-Unicode encoding you obtained in Step 1 - click on OK.

      Example:

    7. Save the changes: go to File menu - click on Save All.

    8. Close the GuiDBedit Tool.

  3. Connect with SmartDashboard to Security Management Server / Domain Management Server and install policy.

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