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"The connection to the Security Management Server <IP address> has been refused because the database could not be opened" error when trying to view database revision Technical Level
Symptoms
  • "The connection to the Security Management Server <IP address> has been refused because the database could not be opened" error pops up when trying to view a database revision.

  • Creating a new database revision / reverting to an older database revision works.
  • "The connection to the Security Management Server has been refused because the database could not be opened" pops up when trying to connect with SmartDashboard to the Security Management Server.
Cause

The root cause for the issue is a large database. 

When trying to view a database revision, the FWM process generates CPMILinksMgr.db cache files for each database revision in $FWDIR/conf/db_versions/databases/<Database revision ID> directory. Since the database is large, the CPMILinksMgr.db file is also large and this causes the connection to time out.


Solution
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