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"Unable to contact Certificate Authority on the Security Management Server" error in SmartDashboard after running "cpstop ; cpstart" commands
Symptoms
  • "Unable to contact Certificate Authority on the Security Management Server.
    Please make sure the Certificate Authority daemon is running.
    "
    error in SmartDashboard after running "cpstop ; cpstart" commands on R77.30 Security Management Server running on Windows OS.

  • "Failed to stop FWD" error in Windows Event Viewer.

  • Output of "cpwd_admin list" command shows that FWD daemon is in the "T" state (terminated).

  • Windows Task Manager (and output of "tasklist | findstr /I fwd" command) shows that the FWD daemon is not running.

  • %FWDIR%\log\fwd.elg shows:
    [FWD PID ...]@HostName[Date Time] sic_server_addrbind_internal: failed to bind on port 256
    Cannot establish fwd service on port 256.: Address already in use

  • After reboot, the FWD daemon starts correctly.

Cause

In SmartDashboard, the following box is checked in Security Management Server object properties: go to "Logs" - go to "Additional Logging" - "Accept Syslog Messages".

As a result, the FWD daemon spawns the syslog.exe process, which inherits all of the FWD's sockets.

The issue is that after the "cpstop" command, the syslog.exe process keeps listening on FWD ports, which prevents the FWD from starting when the "cpstart" command is executed.


Solution
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