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SmartEvent GUI client crashes with "System.AccessViolationException" when connecting to R77.30 SmartEvent server after migrating the database from an older version
Symptoms
  • SmartEvent GUI client crashes when connecting to R77.30 SmartEvent server after migrating the database from an older version:

    1. On Security Management Server R77.20 or lower, export the database using the native Management Server Migration Tool.
    2. Perform Fresh Install of R77.30 Security Management Server (with or without the R77.30 Add-On).
    3. Import the database using the native R77.30 Management Server Migration Tool.
  • Crash Report (AnalyzerClient.exe_<BUILD>_<XXX>.dmp) shows the following exception:

    ***** Crash Info *****
    ExceptionType: Common Language Runtime Exceptions
    Name: System.AccessViolationException
    Code: 0
    Description: An unhandled exception of type 'System.AccessViolationException' occurred in AnalyzerClient.exe
    Additional information: An attempt was made to read the protected memory or write. This is often an indication that other memory is corrupt.
    Frame of Interest: CPDataRepository.dll!CDbBaseObj::GetName!130
Cause

The Management Server Migration Tool overwrote the SmartEvent scheme files of R77.30 with the old ones.


Solution

Use the latest R77.30 Management Server Migration Tool for both export and import of database.

 

To correct an already corrupted database, replace the overwritten files by clean files:

  1. Connect to command line on the Security Management Server / Multi-Domain Security Management Server.

  2. Log in to Expert mode.

  3. On Multi-Domain Security Management Server - switch to the context of the involved Domain Management Server:

    [Expert@HostName]# mdsenv <Domain_Name>
  4. Stop Check Point services:

    • On Security Management Server:

      [Expert@HostName]# cpstop
    • On Multi-Domain Security Management Server:

      [Expert@HostName]# mdsstop_customer <Domain_Name>
  5. Backup the current files in $FWDIR/conf/ directory:

    [Expert@HostName]# cd $FWDIR/conf/

    [Expert@HostName]# cp -v events_db_tables.C log_actions.C log_products.C eventia_event_fields.C eventia_event_details_fields.C sem_views_collections.C sem_products.C /var/log/tmp/
  6. Copy the default clean files to $FWDIR/conf/ directory:

    [Expert@HostName]# cd $FWDIR/conf/defaultDatabase/

    [Expert@HostName]# cp -v events_db_tables.C log_actions.C log_products.C eventia_event_fields.C eventia_event_details_fields.C sem_views_collections.C sem_products.C $FWDIR/conf/
  7. Delete the current SmartConsole cache per sk100507.

  8. Start Check Point services:

    • On Security Management Server:

      [Expert@HostName]# cpstart
    • On Multi-Domain Security Management Server:

      [Expert@HostName]# mdsstart_customer <Domain_Name>

 

 Related solutions:

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