Support Center > Search Results > SecureKnowledge Details
Output of 'cat /proc/cpuinfo' command and of 'top' command show only one CPU core on multi-processor Open Server Technical Level
Symptoms
  • Output of the 'cat /proc/cpuinfo' command shows only one CPU core on multi-processor Open Server.

    Example:

    processor       : 0
    vendor_id       : GenuineIntel
    cpu family      : 6
    model           : 62
    model name      : Intel(R) Xeon(R) CPU E5-2630 v2 @ 2.60GHz
    stepping        : 4
    cpu MHz         : 2592.793
    cache size      : 15360 KB
    fdiv_bug        : no
    hlt_bug         : no
    f00f_bug        : no
    coma_bug        : no
    fpu             : yes
    fpu_exception   : yes
    cpuid level     : 13
    wp              : yes
    flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts mmx fxsr sse sse2 ss nx rdtscp lm constant_tsc up ida pni cx16 popcnt lahf_lm
    bogomips        : 5191.33
    
  • Output of the 'top' command when pressing '1' shows only one CPU core on multi-processor Open Server.

Cause

Possible reason: issues with power supply(ies) while booting the Open Server.


Solution

Follow these recommendations:

Note: Before following the steps below, verify that the BIOS settings are correct (e.g., all CPU cores are enabled, "APIC Mode" is enabled, etc).

  1. Reboot the Open Server.

  2. Run the 'cat /proc/cpuinfo | grep processor' command to see how many CPU cores are reported.

  3. If the issue persists (only one CPU core is reported), then check whether other CPU cores are logically offline:

    [Expert@HostName]# for CPUCORE in $(ls -1 /sys/devices/system/cpu) ; do echo "Status of ${CPUCORE}: $(cat /sys/devices/system/cpu/${CPUCORE}/online)" ; done

    • If the returned value for a CPU core is 0, then this CPU core is logically offline

    • If the returned value for a CPU core is 1, then this CPU core is logically online


  4. Bring logically online the desired CPU cores:

    [Expert@HostName]# echo 1 > /sys/devices/system/cpu/cpu<X>/online

    where cpu<X> denotes a CPU core - cpu1, cpu2, etc. (run 'ls -1 /sys/devices/system/cpu' command).

  5. Run the 'cat /proc/cpuinfo | grep processor' command to see how many CPU cores are reported.

  6. If the issue persists, then:

    1. Contact the Open Server vendor's support to verify the BIOS settings and exclude any hardware issues.

    2. Contact Check Point Support for further assistance.
This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.

Give us Feedback
Please rate this document
[1=Worst,5=Best]
Comment