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Web-app does not work properly due to Mobile Access "Content-Analyzer"
Symptoms
  • Web-app does not work properly. For example: Search button does not respond.
    If the same application was published in Connectra before, it stops working after upgrading to Mobile Access Blade.
  • $CVPNDIR/log/httpd.log file under HTTPD daemon debug shows:
    [APACHE] [CVPN_INFO] Cvpn::WebHandler::analyzeContentTypeByContentBeginning: called for URL 
    

    The URL of the page that is not working / the Javascrpt file that gets broken /etc.

    [CONTENT_ANALYZER] [CVPN_INFO] Cvpn::ContentAnalyzer::analyze: called with (N) bytes
    [CONTENT_ANALYZER] [CVPN_DUMP] Cvpn::ContentAnalyzer::findfirstAsciiChar: visible char at 0
    [CONTENT_ANALYZER] [CVPN_INFO] Cvpn::ContentAnalyzer::analyze: HTML2
    
  • In the HTTP headers that were sent by the internal web server, the content type is not 'text/html'. For example it will be: content-type: text/plain
Cause

Content-Analyzer has recognized the page as HTML. Therefore, Mobile Access Blade performs translation actions that modify the page (for example, adding the floating navigation bar at the top). If the page contains client-side scripts, they might be broken.

The internal web server sends the content type in the headers of the HTTP Response. Connectra product trusted the content-type header. So, if it were, for example, "text/plain", the page would not be touched.

Since some web servers are not configured well, the Content-Analyzer feature was introduced in Mobile Access to determine the content-type of each web page, based on the structure of the content, and not the HTTP headers sent by the server.


Solution
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